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New features of Coulomb 2.5

• We now let users graphically display stresses resolved on any receiver plane. Previously, this was

only available as a numerical file.

• We include an ancillary program, Splitter, that lets one subdivide a planar surface into any number

of rectangular patches. This is very useful for inputting variable-slip source models.

•  For graphic display of dilatational strains, the numerical scale automatically adjusts to the color

range.

•  We provide new numerical output files for some stress/strain/receiver fault combinations (all

output files now identified by an '.cou' extension)

Bug fixes from former versions

• Dilatational strain exponent error in Coulomb 2.0-2.2.0 is rectified.

• For cross-section options, 'x-start' no longer has to be less than 'x-finish.'

• Supplementary information is now accepted with 'y'/'n' responses.

• Program now avoids a mathematical singularity when the calculation depth coincides with one of

the fault edges (this formerly affected the graphical display only).

• Numerous typos, ambiguties, and inconsistencies in the Users Guide have –been remedied
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Chapter 1

INTRODUCTION

Why Coulomb? The rationale and philosophy of this program

Coulomb is intended both for publication-directed research and for classroom

instruction. It is designed to let one calculate static displacements, strains, and stresses

caused by fault slip, point sources of inflation/deflation, and dike

expansion/contraction. The displacements, strains, and stresses can be on calculated at

any surface at any depth.

Not surprisingly, Coulomb is optimized to investigate Coulomb stress changes on

mapped faults and in aftershock files. All calculations are made in a halfspace with

uniform isotropic elastic properties. The program implements elastic dislocation

formulae of Okada [1992] and boundary element formulae of Crouch & Starfield [1983].

Problems such as how an earthquake promotes or inhibits failure on nearby faults, or

will compress a nearby magma chamber, are germane to Coulomb. Another use would

be long-term crustal deformation associated with strike-slip faults, normal faults or

fault-bend folds. Finite deformation is readily visualized with the ‘distorted grid’

options, whereas infinitesimal deformation is mapped with displacement vectors or

color gradient plots.

We believe that one learns the most when one can see the most, and when one can

explore alternatives quickly and easily. So the principal feature of the program is ease of

input, rapid interactive modification, and intuitive visualization of the results. The

program has menus, sub-menus, check-items, and dialogue boxes to ease operation. The

internal graphics are suitable for publication, and these can be easily imported into

illustration and visualization programs for higher-quality figures.

The program, manual, and tutorial files are freely available from

http://quake.usgs.gov/~ross. If you find any problems with the program or manual,

please let us know. Just be patient with our replies; we get a lot of Coulomb traffic.

We encourage you to use Coulomb for your research. If you submit a scientific paper in

which Coulomb was used, please cite: S. Toda and R. S. Stein [2002]. We would also be
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grateful if you would cite King et al. [1994], as Coulomb is an evolution of the 1995

program, GEN, written by Geoffrey King at the Institut de Physique du Globe de Paris.

The Coulomb 2.5 Bundle contents

The Coulomb 2.5 Bundle is available either on CD-ROM or on this web site:

http://quake.usgs.gov/research/deformation/modeling/coulomb/

The bundle includes:

• Coulomb 2.5 standalone application (assign it ~10 MB for best results)

• InputMaker (to make input files automatically or graphically)

• Taper 1.0 (to make input files with smoothly tapering slip)

• EditII (a simple shareware text-editor to make or modify input files manually)

• UTM+ (converts between lat/lon and Cartesian coordinates; we include this program,

written by James Leutgert at the USGS, with appreciation)

Hardware/Software requirements:

• A Macintosh computer with a PowerPC processor (a G3 or G4 Mac is recommended),

running MacOS 7.0 or higher (MacOS 9.2 is better).

• At least 4.7 MB or RAM available to allocate to Coulomb; 10-12 MB is better.

• A color monitor of at least 600 x 400 pixel resolution. A PowerBook screen (1024 x 768

pixels) is fine.

• Microsoft Excel, to read tab-delimited text files(some output files are created as Excel

documents).

Recommended extras:

• A good vector illustration program, such as Adobe Illustrator, is a must.

• A color raster-imaging application, such as Noseys (www.rsinc.com/noesys), which

includes Transform for 2D color gradient, contour, or vector plots; and T3D for 3D

visualization. Transform makes beautiful figures that are a fraction of the size (in Kb)

of Coulomb’s graphic pict files, and permits useful manipulation of the data matrices.

We highly recommend Transform.

• BBEdit (BBEdit Lite is free) is better than EditII for editing input files, because you can

distinguish spaces from tabs. Regardless of the editor, always use a non-kerning

(uniform-spacing) font, such as Monaco, so that numbers stay properly aligned.
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Two notes about this User’s Guide

1. Any particularly important words of wisdom in the manual are printed in red.

2. The images used in the manual to show you what you will see on the screen were

captured at low resolution (72 dpi). But don’t worry: As you’ll learn, its easy to

zoom in and save much higher-resolution images from the program.

Cover images

1.  The front cover image shows the Coulomb stress change caused by 1992 M=7.3

Landers, M=6.5 Big Bear and M=6.1 Joshua Tree earthquakes. See King et al. [1994].

The stress changes, faults and earthquakes were draped over a digital elevation

model (DEM) in ArcGIS.

The inner-cover gives a taste of the possible graphical output of Coulomb 2.5:

2. The top image (Dilatation cross-section option) was generated in Coulomb. The fault

arrows were added in Adobe Illustrator.

3.  The lower left image was created by importing the grid and fault file into Adobe

Illustrator, a drawing program. The numerical Coulomb file was imported into

Transform and plotted as a color gradient image; then it was imported in the

drawing program. The seismicity was plotted in QPLOT and imported into Adobe

Illustrator.

4. The lower right image was created in Coulomb (Displacement cross-section option)

and imported into Illustrator, where the arrowheads were added automatically.

Credits

The cover page and PDF layout of this Coulomb 2.5 user guide has been designed by

Serkan Bozkurt (USGS, Menlo Park). We thank many users for testing the functions,

finding errors and suggesting improvements.
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Chapter 2

A QUICK TOUR OF COULOMB 2.5

To introduce this software, we walk you through a simple example. Here we just want

you to learn the procedure to display and output graphics, and to save the results. Since

this program is not a completely Mac graphical-user-interface ‘event-loop’ environment,

unexpected input can cause Coulomb to crash. Very rarely, a Coulomb crash will require

you to restart the Mac. So we recommend that you save all your current working

documents before you start.

Menus and their pull-down items turn from gray to black as they become possible

options. So, for example, Functions are gray until one selects an input file. Faults remain

gray until one selects a Function that requires an additional Fault selection. Selections in

Functions or Faults that require additional input produce pop-up Extra Input boxes that

disappear when the data is provided. These features simplify life considerably.

To get started this software, you just need Coulomb and the ‘Input Files’ folder. You’ll

soon learn how to make you own input files.

1. To launch Coulomb, double-click the Coulomb icon. A menu bar and “Coulomb 2.5

output” window appear.
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2. Choose Data > Old.

3. Choose the input file “Example-2(LL).inp” from the dialog box, then <rtrn>.

4. Choose Functions > Plot Grid & Faults. This is a check-mark item. Make sure that

“Grid” is checked. Then, choose Calculation > Go.
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5 .  The calculation is performed and the program now displays the result in the

“Coulomb 2.5 Graphics” window on your monitor. It’s a simple grid with a NE-

striking fault in the middle of the grid.

6. If you want to save this image as pict-formatted file, choose File > Save Graphics

window.  You can name it as you like in the dialog box, open and modify it in

Adobe Illustrator or Canvas, etc. To see more detail of the graphic object, there are

two methods to do so. One is to choose Zoom > Zoom In. You can repeatedly zoom

in until it beeps. The other method is to hold down the mouse button on the object,

and drag until you box the area of interest (see next screen shot). Once an area is

selected, choose Zoom > Zoom Selection. When the maximum enlargement occurs, a

beep will sound. If after zooming, you want to revert the image to its original size,

choose Zoom > Revert To Top.
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7 .  You can see the (x, y) position of the cursor by choosing Coordinates > Show

Coordinates. If you set “Plot size = 1.0,” in the Graphics menu under Size, the precise

position of the cursor is indicated in the window. You can use this function to

confirm the fault position, and its handy for identifying the endpoints of a cross-

section line.

8. When any the graphic is displayed, if you want to do anything except “Save file,”

“Coordinates,” or “Zoom,” you might first hit <rtrn>.
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9. After returning to the main window, one of the functions and an input file calculated

in the last execution are indicated. To make a text-based output file, check Data >

Save Input, Save Result, etc. (these are check-items). The content of these text

output files depends on the Function you select. Coulomb lets you calculate using

combinations of Functions and Faults. You can repeat different kinds of calculations

for an input file until the memory is full (five to six executions on a pre-G3 Mac,

perhaps a dozen or more times on a later Mac). A Graphics menu is used for

changing the size and color of objects. The Graphics menu is used when the main

window (text-based) is active. Why don’t you now quit and relaunch Coulomb.
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Output Files (basic scheme)

Menu Selections
(items in menus are grey until they become possible options)

Execution File Output

One or some of
theses can be
checked.

Files saved with
default names
in the same folder
the input file is in;
they will overwrite
unless renamed.

Combinations of three menu selections
make the kinds of output files.

Input/Output options Distortion/Displacement/Stress Stress Resolved on:

("Run")
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Chapter 3

CONCEPTS, DIMENSIONS AND SIGN CONVENTIONS

This chapter briefly explains what’s needed to use this program. These are things you

must understand to use the software correctly, and to avoid unexpected program

crashes, or misleading output.

To launch Coulomb 2.5

There are two ways to launch the program as the normal Mac programs follows.

Double-click the icon or highlight the icon and command-O. The “Coulomb 2.5 Output”

window appears in front.

To quit Coulomb 2.5

There are four ways to quit this program.

1. Choose File > Quit.

2. Short-cut “Cmd-Q”

3. Just click the closed box on the left-top corner of the “Coulomb 2.5 Output” window.

4.  Hit return key twice. You can ignore some message in the window. This almost

always works.

5. If Coulomb freezes or will not quit, perform a ‘forced quit’ by holding down the

Apple + Option + Esc keys.

Calculation procedure

Here is the procedure to calculate from your input file.

1. Launch Coulomb 2.5

2. Data > Old (or Old-Elements) to read your input file

3.  If the main window “Coulomb 1.0 Output” is active, choose whichever functions

you want to try from the Functions menu. Some of these selections trigger requests

for additional input, or let you modify the parameters in new temporary windows.

4. When you calculate Coulomb stress changes (Coulomb Mapview, x-section, or 3D)

or slip-lines (Slip-line Mapview or x-section), the results will also depend on the

friction coefficient and the selected option in the Faults menu. Some of the Fault

options (Specfied fault or Focal Mech. File) trigger requests for additional input.
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5. Choose Calculation > Go. All calculations and graphic plots are performed by this

action.

6 .  You can see the graphic objects in “Coulomb 2.5 Graphics” window. When the

graphics window is active, the menus Zoom and Coordinates become active (they

were formerly greyed out). While the graphic plot is open, you can print, save, and

zoom in on this plot.

7. To perform the next calculation, you must hit <rtrn> to return to the main window

(“Coulomb 2.5 Output”).

8. The program now reverts to the main window. The foregoing process is just one

cycle for the one calculation. If you want to continue different types of calculations,

you can change the Functions and Faults settings. Then choose Calculation > Go as

you did before. If you want to use another input file, choose Data > Old to read it in

to Coulomb.

9. After you have done all calculations, quit Coulomb 2.5.

To change parameters interactively

Most of the settings and parameters have to be changed by modifying an input file using

a text editor. To be flexible with the parameters, however, the software lets you change

some of the input parameters interactively.

1. Fault or dike positions and slip, the regional stress field, and elastic moduli cannot

be changed except by modifying the input file.

2. The output grid, the depth at which displacement, strain or stress is sampled, the

friction coefficient, and all aspects of the appearance of the color plots, can be

changed interactively. These changes are transient and will not permanently modify

the input file. But if you select Data > Save Input, all interactive changes and selected

options will be reflected in ‘Final-Input.cou’. Coulomb overwrites these files each

time you hit Calculation > Go, so rename the file if you want it preserved.

Most such interactive changes are carried out by typing in temporary small windows

whose values are generally accepted when you type ‘y’ (or something else when y is an

possible input value), after which the window disappears. The following submenus give

you extra pop-up windows.

File Observed GPS File (a dialog box asks you to select the file)
Functions All x-section options, Coulomb 3D, Change Friction, Change Target

Depth
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Faults Specified Fault (a dialog box prompts you for the strike, dip, and rake),

Focal Mech. File (a dialog box asks you to select the file)

To save and print files

A pict-formatted graphic object is saved when you choose File > Save Graphics

Window… name it as you like the dialog box, and put it in any folder. (If you do not

rename it, Coulomb will overwrite it with the next saved file.) After saving it, you can

open it by a SimpleText or a more sophisticated graphic applications such as Adobe

Illustrator to modify it.

Text files are saved when you check one or more of the check-items in the Data menu

(Save…). Save Input saves the input file with all current settings that you modified

interactively. Save Result and Save LightRes save tab-delimited text column files that

can be viewed in Excel or displayed graphically by Transform or T3D. Save ElementC

saves the ‘element-condition matrix,’ stress-changes resolved on ‘receiver’ planes

specified in the input file. These text-based files will be saved in the same folder as the

input file, regardless of where the application or its alias is located.

Coulomb 2.5 will also let you print the graphic object in the “Coulomb 2.5 Graphics”

window, or text in the active window. If you want to print the graphics, just choose File

To get a high resolution (300 dpi) pict file, zoom once before saving. The size (in Kb)

of the saved file gets larger and more precise with each successive zoom. When you

open the pict file in, for example, Illustrator, you’ll need to remove a mask that

covers the graphic outside the original window. Once removed, you will see that the

entire graphic is present.
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> Print Graphics Window… If you want to print the window contents, choose File >

Print Window. You can change the Page Setup choosing File > Page Setup.

Prohibited procedures and actions to avoid freezes and crashes

1 .  With the Graphics window active and in front, you may use File, Zoom, and

Coordinates menus. But hit <rtrn> and return to the “Coulomb 2.5 Output” window

before anything else.

2.  You must not do anything while the actual calculation (Go) is continuing. Some

calculations may take a long time so that you have to wait before the plot is

completed. When “Calculation has been done. Hit return key for the next calc” comes up

at the right corner, you can continue.

3.  Make sure that the “Coulomb 2.5 Output” window is in front when you choose

Calculation > Go for the run. If the “ELEMENTS” window is open, it must be behind

the main window.

4.  Even if you allocate a lot of memory for Coulomb 2.5 using command-I, do not

perform more than 10-20 calculations before re-loading the input. Coulomb does not

have any warning message about the memory-full condition and it can suddenly

crash (though it is not fatal). This appears to be less of a problem for G3 and G4

machines. It just takes a moment to quit and re-launch.

Coordinates, units, and sign conventions

Coulomb 2.5 calculates in the (x, y, z) Cartesian coordinate system. In the mapview

projection on the monitor, x is positive from left to right, y is positive from bottom to

top, z is positive upwards for displacement. DEPTH is positive downwards from the

Earth’s surface. We use the standard Aki & Richards (1980) sign conventions for fault

geometry and slip. The units for the input parameters are the following (see Chapters on

Input and Output files for more detail):

Input

PR1   Poisson’s ratio: [dimensionless, 0-1]  0.25 is typically used

E1 Young’s modulus: [bars]  8x105 bars is recommended

FRIC Friction coefficient: [dimensionless; 0-1] 0.4 is a good starting value

Directions, angle, and dip: [degrees]

Grid and fault positions (x, y): [km]
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Depth: [km] downward is positive

Displacements: [m]

Faults: Right-lateral and reverse slip is positive [m]

Dikes: Opening displacement is positive [m]

Mogi point source: Deflation is positive [m3]

S1IN, S2IN, S3IN:  Regional stress, positive in compression [bars]

The regional stresses are used only when either the Functions “Coulomb…” or “Slip-

line…” are selected and when optimally-oriented planes (Opt…) or Focal Mech. File are

selected in Faults. Otherwise they are ignored.

Shear modulus, G .  Young’s modulus [E1] and Poisson’s Ratio [PR1] are input in

Coulomb. To calculate the shear modulus, note that G  = E1/[2(1+PR1)]. So for

PR1=0.25 and E1=8x105 bars, G=3.2x105 bars or 3.2x1011 dyne-cm.

Output

Displacement: [m] North, East, and Up are positive

Shear Strain: [dimensionless] Right-lateral is positive

Principal Strain: [dimensionless] Extension is positive (tensor notation)

Dilatational Strain: [dimensionless] Dilatation is positive

Stress: [bars] Right-lateral and unclamping are positive
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Chapter 4

INPUTMAKER AND INPUT FILES

All calculations in Coulomb require input files; some require successive inputs for which

you will be prompted. If you already have an input file prepared, after launching the

program the file is read by choosing Data > Old, or Data > Old-Elements. If an input file

is inappropriate or improperly-formatted (e.g., it has tabs, or the number of faults is

inconsistent with the ‘#fixed=’, a warning dialog will appear. You must then change the

file or quit the program and modify it using text editor. If you do not have an input file

you can create one interactively by with InputMaker, or by choosing Data > New and

replying to the prompts, or by modifying an existing file in EditII. Here is an input file:

Notice that all parameters in the input file (except for the line starting “#reg1=” and the

first three characters of the source parameters marked ‘#’) need the decimal point after

each number. All format statements are shown at the end of this chapter.

Making input files with InputMaker

InputMaker 1.0, a standalone utility that comes in the Coulomb 2.5 bundle, lets you

build sources interactively. You can do this by entering fault (x, y) coordinates, or by
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drawing the faults on the grid map. And what’s more, you can drop a fault map,

geological map, or satellite image on to the grid as a guide, register it to the grid, and

then trace the faults to automatically enter them in the input file. InputMaker also makes

certain that everything goes into the right place, and lets you view the file as you build

or modify it.

1. Launch InputMaker.  You will see several tabs along the top. The idea is to just fill in

the blanks, moving from one box to the next, and then from one tab to the next. You

can input either Young’s modulus or the shear modulus. After you have finished

filling in the boxes in a tab (such as General or Stress field), hit the ‘OK’ button at the

bottom. When you first do so, the “Grid graphics” window will appear; just pull it to

the side. It is best to fill in the Faults tab last. Remember that the Stress tab, shown

below, will only be read if you select an optimally-oriented Coulomb stress change

or slip-line option. If you hit the ‘Calc. Axes’ button, a calculator will pop up (see

below) to assist you in defining the 3D stress field, since the three axes must be

mutually perpendicular. Close the Axes calculator when done. Hitting ‘Clear’ clears

numbers from all boxes.
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2. When you get to the Fault tab you have several options. One is to indicate the total

number of planar (fault or dike) and point (inflation or shear) sources, and then enter

each source one at a time based on (x, y) endpoints you have previously written

down. After each fault source is entered, hit ‘OK’. You can hit “Show file” to see the

input file with these faults. If you are going to add another fault, close the input file

manually (using the close box in the upper left-hand corner of the input file), then

increment the “fault#”, enter the new fault parameters, and hit the “OK” button.

Fault# is not the number of sub-elements for each fault (the first 3 spaces of the fault

input line), which InputMaker automatically sets to 1. Then hit “Show file” to see the

additional fault in the input file. If the button reads, “Hide file”, just hit it twice and

it will revert. Now select File > Save, name the new input file, and open it in EditII.

(Remember the right-hand rule convention described earlier so that your faults dip

in the intended direction. Its useful to put a fault identifier in the ‘Reference’ box.

The reference will appear in the input file but will not be read by Coulomb; rather

this is for your own book-keeping.)

3. Your other option is to select fault locations graphically. After choosing the number

of faults, click “OK”. The ‘Grid graphics’ window will appear; click anywhere on the

window to make it active. To add a fault or other source, just click on a point in the

grid, drag the mouse to the other end of the fault, and release. The fault will then

appear as a green line. Now click back on the InputMaker window to make it active,

and click “Get position”. The (x, y) values for the start and endpoints of the fault will

be entered. Now enter the slip, depth, etc., and click “OK” at the bottom, and this

source will be added to your input file, or “Clear” if you don’t like it. When you hit
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“OK” the fault on the grid will turn from green to blue. You can repeat this process

as many times as you like, incrementing the “fault #” each time until you have

reached the total number of sources.

4. You can put any jpeg file beneath the grid, and then trace faults over it. Just click once

on the jpeg in the Input folder and drag it on to the ‘Grid graphic’ window. (Or,

File > Import and dbl-clk on ‘IM-map.jpg’ in the input folder.) The jpeg will open

beneath the grid, letting you trace faults to add to your input file. The jpeg will open

with its upper-left corner in the upper-left corner of the grid graphic window. To

register the map to the grid, notice that a line of buttons now appears on the bottom

of the InputMaker screen. You can adjust the map scale (from the default 100%) and

the x, and y offsets (from the 0-pixel default). If your jpeg has a km-scale bar, you can

check to make sure the jpeg and grid scales are the same.

Note: In the ‘fault’ tab,

‘Lateral-slip’: vt-lat. is positive

‘Dip-slip’: reverse slip is positive
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Notice that we have reduced the jpg scale to 70% (you cannot increase it beyond

100%), and shifted it 12 pixels downward to register the grid with the lat/lon frame.

The green line in the middle of the map is the new fault added to the file.

5. When you have built everything you would like into the file, go back to the Fault tab,

and hit “Show list.” (If this button currently reads, “Hide file”, just hit it twice and it

will revert to “Show list.” You can modify any field in the file just as you would in

EditII. Now choose File > Save, and name it what you wish.

6. Launch Coulomb; File > Old, and select the input file you created with InputMaker.
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Fault line at surface

Intersection of
     target depth
       with fault plane 

X

Y

Right-hand rule

(X-start,
     Y-start)

(X-fin,Y-fin)  km

Positioning a fault in the Input file

Slip
shear (right-lateral positive, m)
normal (thrust positive, m)

Mapview

Cross-section

Surface

Target "DEPTH" 
in input file

(X-start,Y-start)
(X-fin,Y-fin)

(top, km)

(bot, km)

Leading edge of fault projected vertically to surfaceFault trace
projected
up-dip Z

Z

Depth (km)
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Explanation for grid and fault position

Output graphic  (for Data>Old>Example_3.inp)

Surface projection
Map view ( Functions > Grid )

start-x, start-y

x-start, y-start

x-finish, y-finish

x-increment
(in this case, 5km)

y-
in

cr
em

en
t

(in
 th

is
 c

as
e,

 5
km

)

finish-x, finish-y

  #   X-start    Y-start     X-fin      Y-fin   Kode  rt.lat    reverse   dip angle     top      bot
xxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx xxxxxxxxxx
  1   -15.1      -17.00     15.20       17.20   100   0.0000    -2.0000     45.0         5.0     15.00     f-1

    Grid Parameters
  1  ----------------------------  Start-x =    -50.00000
  2  ----------------------------  Start-y =    -50.00000
  3  --------------------------   Finish-x =     50.10000
  4  --------------------------   Finish-y =     50.10000
  5  ------------------------  x-increment =     5.000000
  6  ------------------------  y-increment =     5.000000

Input File

Fa
u

lt
G

ri
d

         Fault trace at
       the surface

Fault line
at the target depth
(in this case, 10 km)

     Frame of the fault
projected to the surface

This is not a sequence number, but is used in Chapter 6 for receiver faults.
It should be '1' for source faults. 



COULOMB 2.5
User guide

23

Modifying an existing file in a text editor

1. Click one of the example files we prepared for tutorials.

2. To duplicate it, type ‘d’ holding command key (command + D), or drag the icon

holding option key.

3. Rename it.

4. Launch an editor program such as QUED/M, EditII, or SimpleText, and open the file

using File > Open (command + O).

5. Use a non-kerning (uniform-spaced) font, such as Monaco or Courier. Change the

numbers you want, checking the units and format. If you want to add source or

receiver faults or dikes, you can add a new row. Confirm that the number of the

rows (faults) and the number of the fixed faults (#fixed=  ) in the third row in the

input file are the same. Some of the editors have an option to ‘show invisibles’. If

your editor has the function, make sure that your modified numbers are filled in the

properly formatted areas and there are no tabs. A tab will crash the program.

6. Save the file.

Taper and Splitter

We have two ancillary programs to help you transform simple rectangular sources into

tapered-slip input files (Taper), or into a set of regularly distributed patches (Splitter).

These are presented in Chapter 10 (page 77). Taper allows you to make more realistic

schematic slip distributions without stress singularities at the fault ends.  Splitter

permits you to subdivide a plane for a ‘variable-slip source model’ from a geodetic or

seismic source inversion, such as those in David Wald’s repository,

http://pasadena.wr.usgs.gov/office/wald/slip_models.html.

Structure and format for input files

An input file is composed of parameters for the halfspace, regional stress field, source

fault positions and slip, receiver fault positions, grid information, graphical

representation, and cross section information. See the figure, ‘Structure of Input file’,

which annotates the entries. Coulomb is written in the Fortran 77 language, so you have

to follow the Fortran format to avoid incorrect input. This is also shown in the figure.

The numbers should be filled within the designated areas with appropriate values.

When making or modifying input files, use a non-kerning (uniform-spacing) font, such

as Monaco, so that all numbers align under the xxxxxxxx headers.
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Structure and formats of the Input file

Creating a new input using the Data > New function

1. Launch the Coulomb.

2. Choose Data > New. The “New File” window now opens.

3. You can enter the numbers following the prompts.
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4. In the final stage of the process, a dialog box appears and you can save and name it

as you like.

5. The choose Data > Old, and select the new input file you just created.

Modifying an input file interactively from within Coulomb

If you choose Data > Save Input while the program is running, the parameters you

modified interactively are automatically saved in “Final-Input.cou” in the folder where

the original input file is located. This process does not allow you to modify the elastic

constants, regional stress or fault sources. With Data > Save Input checked, if you are

running a Coulomb calculation for Specified Faults, the strike/dip/rake will be written

to the input file and will automatically load when you use the input file (rename ‘Final-

Input.cou’) again.

Input file used to calculate stress on focal mechanisms

This input file is only used for the calculation for the resolved stress on the nodal planes

of earthquake focal mechanisms. For this you choose Functions > Coulomb Mapview,

and then Faults > Focal Mech. File. To make and modify the files, you have to use a text

editor. The file format is shown below. See ‘FocalMech.inp’ in the tutorial files for more

details. You can create such a file in Excel, by adjusting the column margins to be 11

characters long, and saving it as a ‘Formatted text (space-delimited)’ file. Then, open it in

a text editor to check the formats and add the 3 comment lines. N = the total number of

rows (nodal planes), not the number of focal mechanisms. The ID number in the first

column will appear on the plots so you can locate the earthquakes. Note that like

Coulomb, this file uses Cartesian coordinates, rather than lat/long. You can use the

utility bundled with Coulomb, UTM+, to convert between lat/long and (x, y) values.
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Focal Mechanism Input File

Intact input file & explanation

Input file with invisible mark & format for Fortran 77

Two lines for comments and notes
Total number of earthquake (this should be the same number as listed rows below)

Earthquake number
to be identified

Location of earthquake 
in the Cartesian coodinate
(km)

They should follow the Aki &
Richards' convention (degree)

Short note to be
refered

a150
a150

a30G10.4 G10.4 G10.4 G10.4 G10.4 G10.4

I3

I3

Equal
number
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Chapter 5

TUTORIAL FOR DEFORMATION CALCULATIONS

Here we explore three options, “Distorted grid,” “Dilatation,” and “Displacement,”

for map-view and cross-sections, using color-gradient and vector plots, to display the

deformation field caused by earthquake faulting or volcanic intrusion.

To display the distorted grid in map view

The program Coulomb can produce an image the original rectangle grid distorted by

faulting in an elastic half space.

1. Start the program by double-click its icon.

2.  Choose Data > O l d. And then, select “Example-1.inp” in the dialog and open it

(keyboard short-cut: ‘cmd-O’).

3. Choose Functions > Distorted Grid Mapview. This is a check-item. Make sure that

this option is checked.

4 .  Ignore the Fault menu, because neither Coulomb stresses nor Slip-lines are

calculated.

5. Choose Calculation > Go (keyboard short-cut ‘cmd-G’).
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6. The following graphic appears in the “Coulomb 2.5 Graphic” window. You can see

the undistorted grid in light grey behind the dark grey distorted grid.

7. You can check the fault position relative to the deformed grid. Choose Coordinates >

Show Coordinates. Now the (x, y) position of the cursor appears in the lower left-

hand corner of the graphics window. To tune this feature off, Coordinates > Hide

Coordinates. If you want to save this image, choose File > Save Graphics Window,

as you learned in the ‘Getting Started’ section.

8 .  If you want to change now much the deformation is exaggerated by the grid

distortion, first hit <rtrn> to go back to the main window. And then choose Graphics

> Size. You can see the new “Size” window. The text window also indicates the

input/output files and the selected Function.
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9. In the Size” window, type ‘3’ and input new amount of exaggeration. The default

number that was included in the input file was 10000. This is a multiplier on the

input fault slip. (Eg., if the input fault slip were 1 m, then the slip seen in the

distorted grid would be 10,000 m or 10 km). If you want less distortion, input a value

less than 10000. If you want a more exaggerated distortion, input a large number. As

soon as you confirm the new number and type 0, and the “Size” window will

disappear.

10. Choose Calculation > Go to get the new image of the distorted grid.

11. You can also change the grid size and x- and y-increments of the grid by choosing

Graphics > Grid. When you choose this, a new “Grid” window comes up. You can

type whatever you want to change. After finishing the modification for the grid, type

‘y’ and hit <rtrn>. The window will disappear and you will be back to the main

window. Now Calculation > Go again.
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12. In this tutorial, keep the program activate for the next step and make sure that you

hit <rtrn> and go back to the main window.

To display the distorted grid in cross section

1 .  Dbl-click ‘Example_3.inp’ in the ‘Input Files’ folder. You will see 7 lines of

parameters beneath “Cross section default” at the bottom of the file. If the input file

does not contain such a cross-section default parameter set, Coulomb will prompt

you for them interactively whenever you select a …x-section option in Functions.

You can now close ‘Example_3.inp’ again.

2. Choose Data > Old and select ‘Example_3.inp’. Then choose Functions > Distorted

Grid x-section. This check-item opens the new window to verify or modify the cross

section coordinates. Accept these values by typing ‘y’, and hit <rtrn>.

3. Choose Calculation > Go to show the distorted cross section grid image.
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4. Experiment by zooming in on a portion of the cross-section. Drag your mouse to

‘box’ the cross-section (this will be identified by a light bounding box on the screen),

and then choose Zoom > Zoom Selection. After viewing the zoomed image, choose

Zoom > Revert to Top to return to the original size. Note that the cross-section line is

shown on the mapview.

5.  You can save the image (zoomed or reverted) by choosing File > Save Graphics

Window.

6. To change the cross-section or mapview grid features (e.g. a deeper or coarser cross-

section), go back to the main window, and repeat the procedure explained above.

7. To create and save a default cross-section file. If you are using an input file without a

cross section default, you can edit the input file in EditII manually to add one, or you

can do the following: First plot the Mapview grid, select Coordinates > Show

Coordinates and choose the endpoints of the cross-section, writing these down.

Then choose Data > Save Input. Now select a …x-section Function, and enter the

values interactively that you wrote down, and choose Calculation > Go. Open and

rename the saved input file; it now contains your default cross-section parameters

for future use.

To display the dilatation map view

‘Dilatation’ refers to volumetric dilatation (exx+eyy+ezz) caused by earthquake faulting or

magmatic processes. This program lets you calculate the distribution of the dilatation in

map view at the target depth, or in cross-section. The procedure is similar to the
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Distorted Grid Mapview option. You can proceed with the following without quitting

the program. Choose Functions > Dilatation Mapview. This is a check-item. Make sure it

is checked.

1. Choose Calculation >Go to show the graphic image.

2. If you want to change the dilatation increment in the plot to use the full range of the
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color bar, go back to the main window after hitting the return key, and choose

Graphics > Size. In the “Size” window, type 2 to change “Shade/Color increment.”

Type a larger increment than the default value (for this example, choose 2.0; then

type ‘y’ to close the window.

3.  Choose Calculation > Go to get the new image for the dilatation. Notice that the

dilatation scale has changed to reflect the new 2 x 10-6 strain increment.

4. If you want to get a smaller range of colors in the scale, close the current graphic by

hitting <rtrn>, and then choose Graphics > Image. The “Image” window opens.

Type ‘3’ for the color scale settings, and then choose 2 for the detailed-color scale

(for the dilatation option, B/W is not implemented). After confirming the new

input, close this window by typing ‘y’. Choose Calculation > Go.

To display the dilatation in cross section

To make a plot of the cross-section of dilatation, recall how to make a cross section of the

distorted grid previously.
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1. Choose Functions > Dilatation x-section. When the new window appears, you can

follow the same process as for the distorted grid cross section.

2. After closing the “CrossSection Input” window, choose Calculation > Go.

3. 

Dilatation increment is 2 x 10-6 above, and 1 x 10-5 below, after changing it in Graphics >

Size. Fiddling with the color scale is a valuable way to see things that would otherwise

be missed. Zoom once or twice before choosing File > Save Graphics window to get

higher resolution files, as shown here

4. In these examples you also see the distorted grid (e.g., the anticlinal fold over the

blind thrust). If you do not want to see such distortions, just choose Graphics > Size,

select item 3, the ‘Exaggeration for disp.& dist.’ and change it to ‘1.0’ (e.g., no
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exaggeration). After accepting the revised values by typing ‘y’, Calculate > Go again.

In the examples above, the uplift had been exaggerated by a factor of 5,000. This is

equivalent to 5000 times the input 3 meters of slip, or 1.5 km, as would occur over

geological time. But if you are interested in pressure solution and mineralization, or

fold growth and fault rotation with accumulated slip, these tools may be useful.

5. All …x-section selections also plot the Mapview at the same scale side-by-side. This

makes the x-section options a great place to start modeling, since you get both views

at once.

To display the horizontal displacement map view

You can also make vector plots of the displacement field.  Although the graphic output

does not include arrowheads, the vectors are underlain by the undistorted grid, so the

root of each vector is clear. Also, if you save the pict file of the graphic, you open it in

Adobe Illustrator and put arrows on the ends of the lines automatically (In Illustrator

9.0: ). To show the displacement in mapview, there are two options. One is an absolute

reference frame (the fixed point is very far from the source fault). The other is the

relative displacement from a selected point, since it is often convenient option to

compare geodetic data such as the GPS or levelling observations from a reference

station.

1.  After launching the program and reading the input file using Data > Old, select

‘Example-2(LL).inp’ Then choose Functions > Horiz. Displacement Mapview. You

will get an ‘Extra Input’ box asking if you want to hold a point fixed (in other words,

the predicted displacement at the point will be subtracted from all other points). In

this case, say no by typing ‘n’.

2. Choose Calculation > Go. You can see the graphic output in the graphic window.

Note that a one-meter unit displacement scale bar is shown. The length of the plotted
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vectors can be controlled by the Graphics option. The image you plotted here is

based on the default value included in the input file.

3. To recreate our modified version of this below, and coarsen the grid to 10 x 10 km

(Graphics > Grid, change items 5 and 6), and change ‘Exaggeration for disp.& dist.’ to

30,000  (Graphics > Size, change item 3). Now your plot will look like ours without

the arrowheads. Zoom once to increase the plot resolution, and select File > Save

graphic window. Name it whatever.

4. Here’s what you do in Illustrator 9.0 to show the arrowheads: get rid of the various

bounding boxes with the Direct Selection Tool (white-cursor arrow). Click on one

vector and then choose Edit  > Select > Select Fill & Stroke (all displacement

vectors—but nothing else—are now selected). Then Filter > Stylize > Add Arrowheads

at end with Scale of 70%. We also spruced up the fault and moved the vector scale

into the plot.
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To include a reference point in a horizontal vector plot

1. After launching the program and reading the input file using Data > Old, choose

Functions > Displacement Mapview. This time, reply ‘y’ to the fixed point, and hold

(0, 10) fixed to see some interesting results.

2. Choose Calculation > G o. The reference point is now shown as a large red dot with

no displacement (a portion is shown below).
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To display the vertical displacement in map view

You can make color contour plots just as you did for dilatation map view

1 .  Data > Old, select ‘Example3.inp.’ Then Choose Functions > Vert. Displacement

Mapview. Its likely that you would want the surface displacements, so choose

Functions > Change target depth, and set it to 0.0 km.

2. Now go to Graphics > Grid, and change the x, y increments to 5 km (items# 5 and 6).

Then go Graphics > Size and change the ‘Shade/Color increment’ to ‘0.02’. Now each

color change corresponds to 0.02 m of vertical displacement.

3. Now Calculation > Go. Here is the plot.

To display the displacement cross section

You can also plot displacement vectors in the cross-section. The vectors are projected

onto the cross-section azimuth, with lengths scaled accordingly, and the fault shown

where it is bisected by the section (if the section line cuts a corner of the fault, the fault

image is truncated).

1.  After launching the program and reading the input file using Data > Old, select

‘Example-3.inp’. Choose Functions > Displacement map + x-section. When that sub-

menu is selected, a new window appears. For practice, change the distance and

depth increments to 5 km (for item #3, input ‘5’; for item #4, input ‘30, 5’; then accept
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the changes by inputting ‘y’. If you make a mistake, just choose Functions >

Displacement x-section again).

2. Now choose Calculation > Go.

3. In the graphic window, you can see the Mapview in the left (not shown above), and

the cross section viewed from south in the right side. In the map view, the section line

is shown as black solid line, so you may verify the relationship between

displacements in map view and cross section.

4. You can save and modify the plots (e.g., add arrowheads) as described previously.

You can also change the location of the cross-section. For example, its instructive to

see what the displacements look like just off the end of the fault.

To plot observed and predicted vectors at a specified series of points

Often you want to compare GPS vectors (or levelling elevation changes) with model

predictions, and plot the residual vectors. Here’s how to do it in Coulomb.

1.  Data > Old, choose ‘Izu-1.inp’. Then Functions > Horiz. Displacement Mapview.

Answer no (‘n’) to the ‘Extra Input’ query. Now select Data > Observed GPS File,

and choose ‘Izu-1.GPS’. The first station listed in this file is automatically set as the

reference station in the plot. All observed and modeled vectors are relative to this

site, so its observed and predicted displacements are plotted as zero. The Observed

GPS input file is not tab-delimited, so keep the numbers beneath the stars (as

explained in loving detail in Chapter 7). Here’s what an ‘Observed GPS file’ looks

like:
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2. To get a numerical file of the results, also select Data > Save Result. Now select

Calculation > Go. The source dike is shown in black, and a point source of inflation is

shown by a small blue circle (near Miyake 4). The GPS stations are the red labelled

circles, and observed and predicted displacement vectors are given different colors.

3. You can move the labels around and add arrowheads in Illustrator. You could also

put this above a layer showing a grid of predicted vectors, or a color-gradient plot of

the vertical or horizontal displacements.

4. In ‘Izu-1.GPS’, the first station displacements happen already to be zero. If you select

Data > Observed GPS File and choose ‘Izu-2.GPS’, Miyake 1 is listed first, and you
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will see that all plotted vectors are relative to Miyake 1; it is zeroed out. The output

file is called ‘GPS_Disp.cou’, appears below. Note that the observed and modeled dx,

dy , and dz displacements are shown both with and without the reference-station

displacements removed.

5. You can easily compute and plot the residual vectors. First, in Excel, subtract the

calculated (‘calc-ref’) displacements from the observed (‘obs-ref’) displacements.

Now put the residual displacements into an ‘Observed GPS File’. Remember that

unlike the ‘GPS_Disp.cou’ file, the input file is not tab-delimited, so a bit of

reformatting will be needed. You can now plot the residuals in Coulomb by, and

giving a single source fault little or no slip. The ‘calculated’ vectors will disappear.

To save numerical output of the strain and displacement calculations

After reading in the input file, check Save Result in the Data menu; then select Distorted

Grid or Dilatation (there are Mapview and Section versions of each) from the Functions

menu; then choose Go. This will produce the following file, which can be opened in

EditII but is easier to work with in Excel. If you keep Save Result checked, rename the

file so it will not be overwritten.
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Now close the file if you have not renamed it. With the Save Result option checked in

Data, you can also select Displacement Mapview from the Functions menu; then choose

Go. You can open the file below in Excel as well. Rename this file.

A tip that will save your life (courtesy of Geof King)

1. Keep Save Input in Data checked all the time. When you get a result you like and

bring the graphic into Illustrator, open the associated ‘Final-input.cou’ from EditII,

change lines 1 or 2 (the comment lines) to give the version number of Coulomb you

used and the run date, save it with a new name, and copy/paste the entire file into

Illustrator. You would do this even if you used Coulomb’s numerical output plotted

in Transform, rather than Coulomb’s internal graphic files.

2.  Now select the text in Illustrator and change the font size to 1 pt. You’ll see an

unreadable microdot of text, which you can move to the lower left corner of the

graphic. You can cover it up with a white rectangle, but do not ever remove it; rather,

keep the microdot there all the way to publication. If its covered, it will not detract

from the figure, but when you ‘Select all’ in Illustrator, you will see it.

3. If you ever need to figure out exactly what parameters and version of Coulomb were

used to generate that figure (as happens when reviewers demand changes or

explanations), or you need to re-run the file, just copy/paste the input file back into

EditII (it will automatically revert to 10 pt) and rerun Coulomb.

4. You will soon lose faith in the work of anyone who does not follow this practice.
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Chapter 6

TUTORIAL FOR STRESS CALCULATIONS

Here we calculate static stress changes caused by the displacement of a fault, dike or

point source (we refer to these as ‘source faults’), derived from the strain field shown in

previous sections. We resolve the shear and normal components of the stress change on

‘receiver’ fault planes. The shear stress change is dependent on the position, geometry,

and slip of the source fault, and on the position and geometry of the receiver fault

geometry (including its rake). The normal stress change (‘clamping or unclamping’) is

independent only of the receiver fault rake.

We use the Coulomb failure criterion, in which failure is promoted when the Coulomb

stress change is positive. We’ll explore three kinds of receiver faults: (1) receiver faults

listed in the input file, (2) focal mechanism files, and (3) faults optimally-oriented for

failure, which are a function of the regional stress, the stress change associated with the

source fault, and the assumed friction coefficient.

On the following page are Figures 2 and 3 from King et al. [1994], which graphically

presents the Coulomb stress change resolved on vertical strike-slip faults parallel to the

master fault (Fig. 2a); and resolved on optimally oriented planes (Fig. 2b) for a given

regional uniaxial compression and friction coefficient. In Figure 3, the influence of the

regional stress magnitude is seen on the orientation of the optimal planes, and on the

stress change resolved on these planes. These figures were made by importing the

numerical stress-change output files (‘Save LightRes’) into Transform, and overlaying

the Transform color gradients on the ‘Plot Grid & Faults’ and ‘Slip-line Mapview’ pict

output files.
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 Fig. 2 from King et al (1994).  Illustration of the Coulomb stress change.  The panels

show a map view of a vertical strike-slip fault embedded in an elastic halfspace, with

imposed slip that tapers toward the fault ends.  Stress changes are depicted by graded

colors; green represents no change in stress. (A) Graphical presentation of equation 8 of

King et al (1994), a “specified fault” calculation.  (B) Graphical presentation of equation

13 of King et al (1994), for optimally-oriented strike-slip “opt strike-slip” faults.
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Fig. 3 from King et al. (1994).  Dependence of the Coulomb stress change on the regional
stress magnitude (σr), for a given earthquake stress drop (∆τ).  If the earthquake relieves
all of the regional stress (left panel), resulting optimum slip planes rotate near the fault.
If the regional deviatoric stress is much larger than the earthquake stress drop (right
panel), the orientations of the optimum slip planes are more limited, and regions of
increased Coulomb stress diminish in size and become more isolated from the master
fault.  In this and subsequent plots, the maximum and minimum stress changes exceed
the plotted color bar range (in other words, the scale is saturated).

To display the Coulomb stress change on specified planes in map view

This is the simplest calculation, and is used by most researchers. To resolve the stress,

you need to specify the fault strike, dip, and rake of the receiver planes following the Aki

& Richards (Quantitative Seismology, W.H. Freeman & Co., N.Y., 1980, p. 106), and

shown graphically in Chapter 3 of this manual.

1. Start the program by double-click its icon.

2 .  Choose Data > Old. And then, select “Example-2(RL).inp”. Choose Data > Save

Input.

3. Choose Functions > Coulomb Mapview. Make sure that this option is checked.

4.  Choose Faults > Specified. This action opens an “Extra Input” window. You are

prompted for the strike, dip, and rake of the receiver faults. To keep things simple,

lets use the same values are for the source fault (strike 162°, dip 90°, rake 180°). Once

you input the rake, the window automatically closes. These values will be saved if

∆∆∆∆ττττ    / σσσσr = 1.0 ∆∆∆∆ττττ    / σσσσr = 0.1

Change in Coulomb Stress (bars) on 
optimal right-lateral faults (black)

σr oriented N7°E,  µ = 0.4

50 km

-1.0 -0.8 -0.6 -0.4 -0.2 0.0 0.2 0.4 0.6 0.8 1.0
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you had checked Data > Save Input before hitting Go. Just rename ‘Final Input.cou’

and use it as the input file. Then all previous settings will be automatically followed.

5. Choose Calculation > G o. The Coulomb stress changes shown as rainbow colors are

now in the graphic window. You can also see the legend at the bottom of the

window. Each color box in the grid is calculated at the center of the box, at the target depth

specified in the input file. Calculated values of stress change may exceed the range

shown in the scale bar.

6.  If you want to change the color increments and thus saturation values, close the

graphic window by hitting the return key and choose Graphics > Size. In the “Size”

window, type ‘2’ and input ‘0.2’ for the ‘Shade/color increment,’ and then type ‘y’ to

close the window. Choose Calculation > Go and you will get the image below. If you

want to make a figure with a B/W scale (seven shades of grey are used), return to

the main active window, and choose Graphics > Image, type ‘3’ and select option 1.

And then repeat the calculation (Calculation > Go).

7. Try changing the apparent coefficient of friction using Functions > Change friction.

Change it to 0.0 and you will see that the pattern is now symmetrical since the

normal stress change is not used. You can also change the target depth for the map
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view using Functions > Change target depth. Note that these actions should be

performed with the main window active.

CONVENTIONS Aki & Richards (1980)

Right-hand rule

N

STRIKE

DIP

Reverse

Right-lat

Left-lat.

Normal
-90°

90° 0°

180°

0 ≤ STRIKE < 360° (2PI)
0 < DIP ≤ 90° (PI/2)
-180° (-PI) ≤ RAKE ≤ 180° (PI)

RAKE (SLIP) RAKE

Regional Stress Axes
used for optimally-oriented
Coulomb stress changes

To produce this plot:

Data>Old>
Example-1.inp

Functions>
Show Regional Stress Field

Calculation>Go

(Note: vector lengths are not
proportional to stress so that
you can verify that axes are
mutually orthogonal)

Explanation for Input Parameters (Lines 8-10 in input files)

S1DR=S1 strike (azimuth), reckoned'CW from North (0°≤S1DR<180°)
S1DP=S1 dip (plunge), (-90°<S1DP≤90°)
S1IN=S1initial (at free surface), bars (compression is positive)
S1GD=S1 vertical gradient, bars/km (positive for increase with depth)
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To display Coulomb stress changes on the optimally oriented strike-slip, thrust, and

normal faults (with the fault dip fixed) in map view

“Optimally-oriented” planes are those oriented such that the Coulomb stress change

resolved on them is most positive (in our plots, most red). Here, for example, one

assumes that aftershocks have a range of orientations, and will be most abundant at the

depth, location and with the geometry that most promotes failure. So at every point on

our grid, we find the ‘receiver’ plane along which the resolved Coulomb stress change is

greatest. If the regional stress were zero, there would be a positive Coulomb stress

change on some plane everywhere. But at large distances from a source fault, the

earthquake stress change will be much smaller than the regional stress, so the planes

rotate very little.

To perform this calculation, one must specify the regional stress field in the input file.

“Example-1.inp” contains a sample 3D regional stress field. If you use your own input

file however, make sure it is properly set up. None of this was needed when you

specified the geometry of the receiver planes (Specify Fault), but there you implicitly

assumed that such faults would be active in the regional stress field.

1. Launch Coulomb. Choose Data > Old. Select “Example-2(RL).inp”.

2.  First, view the regional stress field by choosing Functions >Show regional stress

field; then, Calculation > Go. This shows a mapview and x-section plot of the three

principal stress axes. Note that the vector lengths are not proportional to stress

magnitude (otherwise they could be hard to see if the stress were small), but their

magnitudes are listed to the right. Check that the three principal axes are mutually

perpendicular, which is obligatory. This plot is annotated, and the regional stress

parameters are described in Chapter 3, on the Conventions page.

3. Choose Functions > Coulomb Mapview. This option should be checked.

4. Choose Faults > Opt Strike-Slip. Alternatives are Opt Thrust [dip fixed], or Opt Normal

[dip fixed]. These check-items are alternatives to Specified Fault you just tried. You do

not have to input anything in this case.

5. For Opt Strike-Slip the faults dip vertically and their strike is a function of S1 (σ1) and

the friction coefficient µ (FRIC in Coulomb). For the thrust and normal faults, their

dip is a function of the friction coefficient, and their strike is perpendicular to S1 (σ1)

and S3 (σ3), respectively. The relationship of the angle, β, between S1 and the dip (for

strike-slip faults) or strike (for dip-slip faults) is

tan 2β = 1/FRIC
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See King et al. [1994], which can be accessed online from the Coulomb web site at

(http://quake.wr.usgs.gov/research/deformation/modeling/papers/landers.html)

6. Choose Graphics > Grid, and change the x, y increments to 1 km for higher spatial

resolution. Then choose Calculation > Go. Here’s the plot.

7 .  The Coulomb stress changes shown as rainbow colors are now in the graphic

window. Try making further adjustments, such as Functions > Change Friction or

Change Target Depth; or Graphics > Size to change the stress increment so the color

scale bar will not saturate.

To save the stress calculation results as text column file

Although the program lets you save the calculation results as pict files, you may want to

examine the numeric values or make higher quality figures. Coulomb color files can be

large when the increments are small, so bringing numerical files into raster imaging
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software can both increase the image quality and decrease the file size. Here’s how to

save the text column to be read by Excel (open and hit ‘finished’) Noesys (Transform,

T3D; open them as ‘text-column’ and follow prompts).

1 .  Check Data > Save LightRes before you execute Calculation > Go in the above

procedure. The output file is created in the same folder as the program Coulomb.

Check to see that the new file is in the folder after the calculation is completed. It is

automatically named depending on the calculation type. Subsequent runs will

overwrite the original data file unless you rename it before making new runs. See

Chapter 8 for detailed descriptions of the files and formats.

2. From this file you can plot the normal-stress changes in Transform (which Coulomb

will not do), or re-evaluate the effect of the friction coefficient, since both

components are listed. It would be wise to import the Input file into the Excel file so

you can re-generate the output. Rename the Excel file if you plan more runs.

3.  You could also have checked Save Result, which returns an additional six stress

components rotated into the fault (f) coordinate system (sigfx, sigfxy, etc). They are

likely more than you want; we use them principally for debugging.
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To plot the slip-lines (the fault planes) for the optimally-oriented strike-slip, thrust, and

normal faults

The program Coulomb lets you plot the planes for the optimally-oriented Coulomb

stress changes in map view and cross-section. We recommend you look at both the

stress changes and the optimal planes; if the regional stress is low relative to the

earthquake stress change, the planes rotate near the source fault. Here’s how to do it.

1. Quit and relaunch Coulomb unless you allocated a lot of RAM to Coulomb.

2. Choose Data > Old. Select “Example-2(RL).inp”.

3. Choose Functions > Slip-line Mapview. Make sure its checked. One typically uses a

coarser grid so adjacent slip-lines do not overprint, so set it to 10 x 10 km in Graphics

> Grid. The slip-line length is controlled by Graphics > Size (‘Exaggeration for disp.

& dist.’); set this to 10,000.

4. Choose Faults > Opt Strike-Slip, also a check-item. Once again Coulomb will read

the regional stress field and the friction coefficient from the input file to draw the

slip-lines. Choose Calculation > Go.
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5. For the Opt Strike-Slip option, the right-lateral and left-lateral optimal planes are

red and blue, respectively. You can overlay these on the stress change plots. When

we do so, we often remove the planes over the negative Coulomb sites (the blue

regions), because although the stress change is most positive along these planes, it is

nevertheless negative, and so we would not expect aftershocks there.

6. The Coulomb stress change on each pair of red and blue planes is identical at the

point where they intersect. For a friction coefficient equal to zero, the planes would

be orthogonal, and we could compare them to aftershock focal mechanisms

unambiguously. But the planes are acute for high values of friction, as explained by

King et al. [1994]. Try checking this by selecting Function > Change Friction. For

normal and thrust planes, the strike for the two planes is the same and their dip is a

function of the friction coefficient.

To plot and produce a numerical output file of the principal stress axes for optimally-

oriented faults

1. Choose Data > Old. Select “Example-2(RL).inp”.

2. Choose Functions > Slip-line Mapview. Make sure its checked. One typically uses a

coarser grid so adjacent slip-lines do not overprint, so set it to 10 x 10 km in Graphics

> Grid. The slip-line length is controlled by Graphics > Size (‘Exaggeration for disp.

& dist.’); set this to 10,000.

3. Choose Faults > Primary Axes, also a check-item. Coulomb will read the regional

stress field from the input file to draw the slip-lines. Choose Calculation > Go. Here’s

what you will see. Notice that the axes rotate and σ3 deviates from being vertical

close to the source, as a result of the stress changes imparted by the earthquake.
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4 .  Now to get the numerical file, choose Function > Coulomb Mapview and then

Faults > Opt fault. This will produce a ‘Coul.Map-opt.cou’ file, which you can open

in Excel. Only part of the file is shown here.

To plot Coulomb Stress change in Cross-section

Here we use Opt Thrust, where the fault dip is not fixed. Rather, the dip maintains a

fixed angle to the total (earthquake + regional) σ1, and σ1 need not be horizontal close to

the earthquake source, where the earthquake stress change can be large. Thus Opt thrust

and Opt thrust [dip fixed] should differ only near the source, where Opt thrust will be
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more positive (redder). For Opt Fault, not only the dip but the rake is also free to change

to optimize the positive Coulomb stress change. Therefore Coulomb stress changes for

Opt Fault will generally be the most positive of all (although we have not fully tested

Opt Fault, so beware).

For this example, choose Data > O l d; select ‘Example-2(TH).inp. Then Functions >

Coulomb x-section, Faults > Opt Thrust. Then Calculate > Go.

Coulomb cross-sections do not have to be vertical. An invaluable use of dipping cross-

sections is explained on p. 59, in the section, ‘Graphically displaying stress changes

resolved onto receiver faults.’

To make a 3D image of the Coulomb stress change

In addition to the map view plot of the calculated stress result, you can make pseudo-3D

images constructed from successive mapview planes. These are especially useful for

studying stress changes associated with dip-slip faults, because unlike strike-slip faults,

the stress changes are very depth-dependent. Numerical values can also be saved for

export into scientific image rendering software, such as T3D in Noesys.
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1 .  Select Data > Old, and use ‘Example-2(TH).inp’. When you choose Functions >

Coulomb 3D, the new window opens and you can input the depth range of the 3D

image and the sampling increment in depth (the z-direction). Try, 0, 25, 5 for the

upper depth, lower depth, and depth increment. Then select Faults > Opt Thrust,

and Calculation > Go.

2. To get images quickly onto the screen, it would be better if the number of slices were

no more than six, because one can only view 6 small map views in the Graphics

window. You can then re-run with a finer depth increment, and open the file,

checked as Data > Save LightRes, into T3D. Note that the bold black line changes

position with depth, because this line is drawn where the fault plane (if solid), or its

up- or down-dip projection (if dashed) intersects the horizontal plane at the stress-

sampling depth.

3. To save the 3-D text column file, Data > Save LightRes (a check-item) before the

calculation. See the figure on the following page, rendered with T3D in Noesys. For a good
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3D image, we recommend setting the x and y increments to be equal. Keep in mind

that 3-D text column files tend become huge, but T3D has no problem opening them.

3 D images made by Coul-3D-LightRes.cln with T3D (Noesys)

Isosurface rendering (e.g., 0-bar surface)

Slice rendering + Isosurface rendering

Examples

T3D can be purchased from www.rsinc.com/noesys
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Chapter 7

TUTORIAL FOR ADVANCED FEATURES

Resolved stress change on mapped faults

To study the stress changes on active ‘receiver’ faults surrounding a ‘source’ fault (with

slip or opening), we must resolve the stress change on the receiver faults, which

depends on their location, geometry and inferred slip vector. It is difficult to obtain such

values from the gridded calculations you have thus far learned to make. Here we place

the receiver faults in the input file, with no slip (the two columns for the slip

components in the input file are both set to zero). For simplicity, we always list these

receiver faults after the source fault(s). We use “Example-1.inp” for this calculation.

Open the input file using text-editor software such as EditII.

You can see three faults listed (three rows) in ‘Example-1.inp’ (above), but the two have

no slip. These are receiver faults. In addition, you can see the first column in the fault list

(labelled #, for number of segments), we have divided each receiver fault into five

elements. This enables you to sample the stress along the receiver fault plane without

the cumbersome task of inputting many faults. Now launch Coulomb. The following

procedure is used for the element calculation.

1. Choose Data > Old-Elements.

2 .  Now, you can see that two receiver faults produce 10 lines of ‘Element

Displacements.’ Put the main window is in front by clicking on it anywhere. Now

choose Functions > Grid & Faults; then Calculation > G o. We have annotated below

what you will see on the screen.
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3 .  Now choose Data > Save ElementC. This is a check-item, which produces the

“ElementCondition.cou” file automatically in the program folder.

4 .  Choose Functions > Coulomb Mapview (or Coulomb x-section or 3D). For the

purpose of examining the stress condition on elements, it does not matter which you

choose. An ‘ElementCondition.cou’ file will be created as long as few as two points

of a grid are calculated, so to save computation time, increase the x, y increments so

the grid is very sparse. (Or, you can simultaneously save the numerical Coulomb

values at the grid points, as you have done before, and the Element Condition file,

by selecting Data > Save LightRes. Both items should then be checked in Data.

5. Choose Calculation > Go. The graphic window appears. You can ignore the coarse

stress result calculated on grid in this case. Hit <rtrn> and the main window

indicates that a file, “ElementCondition.cou”, has been saved.

6. Quit Coulomb and launch Excel.

7. In the Excel, choose File > Open and open “ElementCondition.cou”. Because the file

is tab-delimited, just hit Finish and all columns will be labelled.
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8. In the Excel spreadsheet (only the left half of the file is shown above), each source and

receiver fault element is in its own row, along with the (x, y) coordinates of the

center of each element at the target depth. In addition, the segment geometry, slip

(non-zero for at least one component for sources, and zero for receivers), shear,

normal, and Coulomb stress; and the stress tensor components. We generally delete

the rows for the source(s), particularly if there are hundreds, as is often the case for a

variable-slip earthquake models. The EC files show the horizontal (right- or left-

lateral), dip-slip, and maximum resolved shear stress and its associated rake

direction, the normal stress change, Coulomb stress, and a myriad of other

components. See page 73 for an invaluable annotated ‘Element Condition’ file.

Graphically displaying stress changes resolved onto receiver faults

Although the stress changes on the receiver faults are tabulated in the

‘ElementCondition.cou’ file, often one would like to visualize these stress changes. One

can do this selecting the ‘Coulomb x-section’ option, and choosing a cross-section co-

located with a receiver fault plane. Such a cross-section can have any orientation, and

need not be vertical. Here is an example:

Here are the three faults in Example-1.inp:

Choose Data > Old, and select ‘Example-1.inp’. Then choose Functions > Coulomb x-

section. Now change the x-, y-start, x-, y-finish, and the dip to be the same as for

Receiver fault 1 in the input file. Next, change the Z-depth to correspond to ‘bot(km)’ in
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the input file. Finally, let’s make both the along-strike (‘Distance increment’) and vertical

(‘Z increment’) increments to be 2 km. After making these changes, the final

‘CrossSection Input’ dialogue box should look like this:

Now choose Faults > Specified Fault. Here you want to resolve the stresses onto the

plane of the cross-section plane, which is the same as the Receiver fault 1 plane. So you

input strike = 213.68°, dip = 65°. These values are shown in the ‘ElementCondition.cou’

file on page 59 for Receiver fault 1. (If you hadn’t saved this file, you could re-enter

‘Example-1.inp’ as Data > Old-Elements and read the strike and dip of the receiver fault

1 sources from the screen).

Now choose the rake of interest to you. You could, for example, select the rake that

maximizes the shear stress change (identified as sig-max in ‘ElementCondition.cou’),

called rake-max in ‘ElementCondition.cou’ above. So set rake = -5°. The ‘Extra input’ box

should then look like this:

Now choose Calculation > G o. You can also see the A, B marking the endpoints of the

cross-section. Of course you can save and edit this graphic file by hitting the File > Save

Graphics Window.
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You can output the numerical file of these stresses by checking Save LightRes and hutting

Go; then open the resulting file, ‘Coul-Sec-Spec.cou,’ in Excel. Notice that you are

calculating the left-lateral Coulomb stress on planes roughly parallel to the right-lateral

source fault, so the stress shadow looks red. If you had chosen a rake = 180° (Coulomb

stress changes on right-lateral faults), the stress shadow, as well as the stresses resolved

on Receiver fault 1 in the cross-section, would be blue. You might try this.

Freely slipping boundary elements under plane stress (Kode 105 faults)

If you are studying strike-slip faulting, Coulomb allows you to calculate the amount of

slip a fault would undergo to release the stress imposed by a source fault. The receiver

fault is treated as a freely slipping boundary element (a fault with zero internal friction)

when the Kode is set to 105, rather than 100 as used for elastic dislocations. This is based

on the two-dimensional boundary element method developed by Crouch & Starfield

(1983). Kode 105 faults must be vertical, but their top and bottom depth can be set as

desired.

Here is an example of how one can use Kode 105 faults. One calculates the shear stress

resolved on the San Andreas imposed by the 1992 Landers earthquake. In places it is
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right-lateral; elsewhere it is left-lateral. How much would the San Andreas need to slip

to shed (or relieve) this added stress? The answer obtained [King et al., 1994] would be

different if you let the freely slipping boundary elements lie in the upper 10 km, or if the

elements extend from great depth to a minimum depth of 10 km. Further, the longer and

wider a fault, the more it will slip, given the same applied stress. Another example of

Kode 105 fault use is how the San Andreas in the creeping and Parkfield section would

need to slip to shed the stress imposed by the 1983 Coalinga thrust earthquake 25 km

away [Toda & Stein, submitted to JGR, 2001].

Setting up the input file with Kode 105 boundary elements [see ‘Example-5-(105kode-

1).inp’ above, a simplified 1992 M=7.3 Landers rupture, as a guide]:

1. You must list the Kode 105 faults before the elastic dislocations (kode 100 faults) in

the input file. The regional stress field is ignored for this calculation.

2. Set ’#reg 1=’ in the third line of the input file to the number of rows of Kode 105

faults. If you have one freely slipping boundary element divided into 10 patches, you

still put ‘#reg1=1’, and you designate the 10 patches or elements by putting ‘10’

beneath the ### in the first 3 characters of the input line.

3. Make sure that Young’s modulus (E1) and Poisson’s ratio (PR1) for region 1 have

reasonable values in the input file.

4. Ensure that the source faults listed after the receiver faults are set as Kode 100. Once

you read the input file using Data > Old-Elements, you can immediately see the

released slip on the receiver faults in the “ELEMENTS” window (see below) .

Remember the sign convention for slip: positive for right-lateral and negative for

left-lateral. Thus, in this simplified example of the 1992 Landers earthquake, the Big

Bear fault would need to slip 3-4 cm left-laterally to shed the stress imposed by

Landers.

5. For a text output file, choose Data > Save ElementC. Then, Calculate > Go. Then open

‘Element Condition.cou’ in Excel.
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       ‘Specified’ fault with Big Bear parameters              ‘Opt strike-slip’ Fault

    
The figure on the left is the Coulomb stress change (µ=0.4) on specified left-lateral

planes parallel to the Big Bear rupture (one finds a 1-bar increase at Big Bear). The figure

on the right is the Coulomb stress change (µ=0.4) on optimally-oriented strike-slip

planes, given the N7°E regional compression axes (one sees a 2-bar increase at Big Bear).

Pure red is 2.0 bars. The boundary element experiment suggests that because the fault is

short, it could only slip 3-4 cm to relieve this stress increase. The Big Bear fault ruptured
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in a M =6.5 shock 2 hr after the Landers mainshock, slipping about 50 cm in the

processes.

6. Make the main ‘Coulomb Output’ window active again before selecting Data > Save

ElementC . Then Calculate > Go. You obtain the slip values in the

“ElementCondition.cou” file after you finish the Coulomb calculation. When

viewing ‘ElementCondition.cou in the Excel spreadsheet, the column for “lateral

slip” of the Kode 105 faults now gives the slip caused by the source fault. Note that

the program cannot calculate the dip-slip component of a Kode 105 fault, so it is

always shown as zero. We have yet to implement Kode 105 for faulting in dip-slip

environments.

Crack opening or closing (Tensile Kode 200 sources)

Many magmatic intrusion problems require a dike or sill source undergoing expansion

or contraction. Here we introduce the deformation and stress change caused by a tensile

component of displacement, such as the opening or closing of a tabular or crack-like

body, using the equations of Okada [1992]. For simplicity, the input file format for the

Coulomb has only two slip components, labelled ‘right.lat’ and ‘reverse’. So, when you

change the Kode of the source to 200 or 300, the first of these slip components takes on a

tensile-displacement interpretation by the program, as described below.

1. Kode 200 permits tensile slip and strike-slip to be input. For Kode 200, put lateral

slip in the ‘rt-lat.’ column and tensile slip in the ‘reverse’ column (dike opening is

positive; unit = meters).

2. Kode 300 permits tensile slip and dip-slip to be input. For Kode 300, put tensile slip

in the ‘rt-lat.’ column (again, dike opening is positive), and put reverse slip in the

‘reverse’ column.

3.  If the element has three components of slip (strike-slip, dip-slip, and tensile-slip),

you can accomplish this by using a combination of Kode 200 and 300 elements as

shown in the file below, ‘Example-7(200-300kode).inp’.

4.  Define the dike geometry (endpoints, dip, and top/bottom depth) as you do for

faults. Unfortunately, the way we define faults/dikes does not permit one to put in a

strictly horizontal plane, since the top and bottom depths would be identical, but

you can put a tiny dip (~1°), and it will work fine.
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5. Uniform opening or closing of a dike is likely to be unrealistic. Just as you can for

faults, you can taper the displacement toward the edges by running the program,

Taper, which is explained in Chapter 10.

Point source of deflation or inflation (Kode 500)

We have implemented the formula from Okada (1992) for a buried point source of

expansion or contraction. Of course the calculated stress changes very close to such a

point source are infinite and are thus unreliable, but at larger distances, this source is

valuable for magmatic intrusion problems, such as studying how an intrusion event

may bring other faults or dikes closer to failure. An example of this is Nostro et al., Two-
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way coupling between Vesuvius eruptions and southern Apennine earthquakes by

elastic stress transfer, JGR , 103, 24,487-24,504, 1998, which is on our web site at

http://quake.usgs.gov/research/deformation/modeling/papers/nostro.html. As with

the dike/sill source, we have created two kodes for mixed volumetric and shear

displacements.

1. The unit for deflation or inflation is potency (m3), the volumetric change associated

with the evacuation or expansion of a spherical magma chamber. Contraction is

positive. Potency, also called the ‘geometric moment,’ is equivalent to the

seismic moment/G, where G is the shear modulus. As discussed previously (see

boxed equation in Chapter 3), in Coulomb one inputs Young’s modulus (E1) and

Poisson’s ratio (PR1), from which G can be computed. The units for the strike or dip

slip is meters, as usual. One designates the source as Kode 500.

2. Kode 500 permits both a dike and point source of expansion to be input. Put the

tensile opening in the first (‘rt-lat.’) column (units are m. opening is positive), and put

the point source in the ‘reverse’ column (units are m3, contraction is positive).

3. The location of the point source is defined by a plane in the input file. The point is

located at the midpoint of the start and end positions, and at the midpoint of the top

and bottom positions. The plane defined by this geometry is used for the dike

opening. So if you only calculate the point-source expansion, the length and width of

the plane are unimportant; if you also want to consider opening or closing of the

planar dike, then these dimensions are important.

4. The point source is indicated graphic output files as a small blue circle. Note that a

dike expansion and a point-source of inflation were used in the observed and

predicted GPS displacement example plotted in Chapter 4.
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The following figure was made using ‘Example-9(Kode500).inp’ for with the Function

Horiz. Displacement Mapview, with no reference point chosen.

Earthquake point source (Kode 400)

To conveniently model the stress changes associated with small earthquakes or

aftershocks, it may be useful to use an earthquake point-source. Such an approach is

invalid close to the source, where the stress changes are infinite. Nevertheless, often one

knows only the focal mechanism and the seismic moment of a shock, which is

proportional to the slip times the area. A grid of point sources could also be used for a

variable slip model, although this is probably easier to do by defining many adjacent

rectangular patches. Here is how Kode 400 sources are defined in the input files:
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1. The unit for the source is (m3), the slip x length x width. Right-lateral and reverse slip

are positive, as usual. The unit is equivalent to the Moment/G, where G is the shear

modulus.

2. The location of the point source is defined by a plane in the input file. The point is

located at the midpoint of the start and end positions, and its depth lies at the

midpoint of the top and bottom positions. The plane defined by this geometry gives

the strike, and dip is input as usual.

3. Point sources are indicated in graphic output files as a small blue circles. To verify

the strike of the point sources, choose Data > Old-Elements and look at the

‘ELEMENTS’ window, or choose Data >Save ElementC, then Calculation > G o, and

open the resulting ‘ElementCondition.cou’ file in Excel.

Resolved stresses on nodal planes of aftershocks

One powerful approach to Coulomb analysis is to examine stress changes on the nodal

planes of seismicity or aftershocks, to answer the question, are the aftershocks brought

closer to Coulomb failure by their main shock? Aftershocks are a rich source of such

nodal-plane information. To examine if such earthquakes occurred on favourably

oriented fault planes, the program can read another type of seismic-catalogue file

(formatted for the nodal planes), and it calculates stress on the two nodal planes of each

mechanism (or only one if you can eliminate one of the two alternatives). The input file

is described in detail in Chapter 7. Each nodal plane is a separate line, so a typical

aftershock occupies two lines, one for each nodal plane. Here is the procedure.

1. Launch Coulomb; Data > Old, choose ‘Example-1.inp’ (any input file would suffice).
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2 .  To plot the numbered earthquakes on the grid, choose Functions > Coulomb

Mapview. (The epicentres will not be plotted by the normal ‘Plot Grid & Faults’

Function).

3. Choose Faults > Focal Mech. File, and then a dialog box appears.

4. In the dialog box, select an input file formatted for the focal mechanism calculation

(we prepared “FocalMech.inp” as an example; its in the ‘input files’ folder).

5. Choose Calculation > Go. The grid, faults, and numbered earthquakes appear in the

graphic window; the Coulomb stresses are not drawn. You can check the aftershock

locations and also save this image as a figure. The calculated results are

automatically saved as “FocalMech.out” in the folder where Coulomb is located.

6.  After quitting the program, open the “FocalMech.out” file in Excel (only the left-

hand side of the file is shown below). You can examine not only the stress changes

on the nodal planes given the observed rake, but also many other components (such

as the maximum Coulomb stress change for the optimum rake). See chapter 8 for the

detailed explanation of the components listed in “FocalMech.out”.
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Note: That you can use the ‘Focal Mech. File’  to calculate stress changes on

receiver faults specified by strike / dip / rake /x / y / z, rather than in the

standard input format of start x,y / finish x,y / rt-lat / reverse / top / bot.

This is often useful when working from standard earthquake - formatted

data
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Chapter 8

OUTPUT FILES

Coulomb allows you to save graphic images (pict files) and text (ascii files).

Pict-formatted files of graphic images

All graphic images are saved by choosing File > Save Graphics Window… while the

graphic window (“Coulomb 2.5 Graphics”) is active. You can save it to whatever folder

you would like and name it whatever you wish. The saved pict-formatted file is

composed of objects, such as grid lines, fault lines, color squares, etc., and a bounding

frame. If you double-click the saved pict file, SimpleText automatically opens the image.

To edit the file, open the file from File > Open command from Adobe Illustrator (or any

graphic application that can handle pict file), and you can easily modify and group

them. It is very useful, for example, to place the undistorted grid file in one layer, and

the Coulomb color gradients in another layer.

Text files

The text output from Coulomb 2.5 is automatically saved in the same folder with the

input file, with default names as shown in the figure “Output files (combinations & file

names).” There are many kinds of column files that depend on the combination of Data,

Functions, and Faults. Most of these are tab-delimited column files, which can be easily

opened in Excel. They are also easily changed into matrix files using Transform, and the

Data Utility in Noesys (or other matrix-display applications). This permits more

sophisticated color gradient graphs and color rendering images, and further

manipulations of the numeric files. “Final-Input.cou” should be opened by a text editor,

such as EditII, rather than Excel, as it is not tab-delimited. Annotated screen shots of the

various output files opened in Excel follow in the next several pages.
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Output Files (combinations & file names)

File name to be saved

Final-Input.cou

Displacement.cou

Coul-Map-Opt.cou
Coul-Map-OptSS.cou

Coul-Map-OptTH.cou

Coul-Map-OptNO.cou

Coul-Map-Spec.cou

Coul-Sec-Opt.cou
Coul-Sec-OptSS.cou

Coul-Sec-OptTH.cou

Coul-Sec-OptNO.cou

Coul-Sec-Spec.cou

Coul-3D-Opt.cou
Coul-3D-OptSS.cou

Coul-3D-OptTH.cou

Coul-3D-OptNO.cou

Coul-3D-Spec.cou

Coul-3D-LightRes.cou

ElementConsidition.cou

FocalMech.out
with FocalMech.inp

Coul-Map-LightRes.cou

Strain.cou

Vol_dilatation.cou
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Fault number

Kode number

It numbers ascending order to the bottom.
If a fault has multiple segmented
elements, they are listed in here separately.

Depth is controled by the input target depth.
X, and Y indicate the center of the fault (element)

The program can read four types of kode numbers.
100: none-open fault (element) condition in a half space
105: two dimensional lateral freely slip fault (element)
200: crack type fault (element) condition in a half space [lateral shear + tensile]
300: crack type fault (element) condition in a half space [tensile+ normal shear]

Coordinate (x,y,z) of the calculation point

N

STRIKE

DIP

One fault segmented into 3 elements

In code 100, 200, and 300, 
souce fault has slip indicating
below. Receiver fault however
does not have any slip.

In code 105, the amount of
the freely-slipped lateral 
  displacement of the receiver
     fault is indicated. 

Calculation point

Target
     depth

Z

Lateral slip (m)
[left-lat. is positive]

Dip slip (m)
[thrust comp. is positive]

Element Condition File

Without Regional Stress With Regional Stress
Common value,
because of fixed fault plane

Coulomb stress change in the strike-slip direction Coulomb stress change in the dip-slip direction

Maximum Coulomb
stress change
(rake indicated by
'rake-max' column)

Rake-max (degree)

Resolved shear stress
on source & receiver
faults

Sig-right (bar)

Sig-up (bar)

Sig-max (bar)

Rake-max(+r)
          (degree)

Sig-right (bar)

Sig-up (bar)

Sig-max (bar)

Sig-max(+r) (bar)
σ1

σ3

σ2

Coul-max = Sig-max +  µ' x Sig-nor
Coul-max (+r) = Sig-max (+r) +  µ' x Sig-nor

Six components of stress tensor
at the calculation point
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FocalMech.out File

Cartesian coordinates (x,y,z) of 
the hypocenter

One of nodal planes
(Aki and Richards convention)

Max-dir(+r)
          (degree)

Sig-right (bar)

Sig-max (bar)

Sig-max(+r) (bar)
σ1

σ3

σ2

With Regional Stress

Sig-up (bar)

Max-dir (degree)

Resolved shear stress
on one of nodal
planes

Shear stress along the observed
slip direction

Sig-right (bar)

Sig-thrust (bar)
Sig-max (bar)

Without Regional Stress

Sig-obs (bar)

Coul-max = Sig-max +  µ' x Sig-nor
Coul-thrust = Sig-thrust +  µ' x Sig-nor
Coul-right = Sig-right +  µ' x Sig-nor
Coul-obs = Sig-obs +  µ' x Sig-nor

Coul-max (+r) = Sig-max (+r) +  µ' x Sig-nor

Normal stress to
the nodal plane Short notes



COULOMB 2.5
User guide

75

Chapter 9

GRAPHIC TOOLS

Most graphic settings are specified in the input file, such as the grid boundaries and

increments, and the plot size and exaggeration for displacements and vectors. However,

these can be interactively changed form the Graphics menu. In addition, certain graphic

features are only accessed through the Graphics menu (see next figure). The default

color bar scale, for example can be changed to a more detailed color scale, and for some

plots, a gray scale. The color of the source and receiver faults can also be implemented

through the graphics window. A common use of the Graphics menu is to change the

‘Shade/Color increment’ of a Coulomb plot so that the range of colors is fully exploited

in the plot, or to saturate the colors in certain regions.

When you are in the Graphics Window with a plot on the screen, note the features you

would like to change to alter or enhance your plot. Then hit return in the graphics

window to close the plot. Now go to the Graphics menu to make these changes. When

you are finished, re-make the plot by selecting Calculation > Go.
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To control graphic objects in the ’Coulomb 2.5 Graphics’ window

You must return to the main window to choose a
submenu in Graphics menu.
As soon as you choose one of them, a small window
appears. You can change the parameters in the
window. And then, you have to type 0 and hit return
key to close the window, before the calculation

Show current (command U) also opens a window, in which you can
checkthe current settings of all graphic control parameters.

Each unit is km. These changes
not only grid for graphics but
actual calculation area and
samplings

1) and 2) are switches if the
fault is filled the color or not
(only frame).
3) controls color image. The
program has three options.
Default is seven-color image.

These are arbitrary values.
1) Plot size controls the size of
entire graphic object. But, if the
object become larger than window
size, you cannnot get the image. If
you use 1.0, you can use
’Coordinates’ menu while the
Graphic window is active.
2) Shade... is used for the dilatation
and Coulomb functions.
3) Exagg... control the vector length
of displacement, amount of
deformation for distorted grid,
length of slip line project for
Coulomb calculations.
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Chapter 10

Taper  and Splitter

Taper is a useful stand-alone utility that allows you to create input files for planar faults

or dikes with slip that varies in a regular manner along strike or down dip. Uniform slip

models create stress concentrations near the fault ends that are unrealistic; taper enables

you to avoid this. One reads in an input file with a standard rectangular fault or faults.

One then interactively selects how slip is to diminish or taper toward the ends. Taper

also calculates the seismic moment of each fault in an input file, which is useful even if

you do not want to create a tapered input file. Taper controls the slip so that the seismic

moment of the tapered-slip fault is identical to the starting uniform-slip fault. A new

input file (‘Tapered.in’) is created in the folder in which you placed Taper. You should

rename Tapered.in, because Taper will overwrite successive ‘Tapered.in’ files. This input

file can then be read into Coulomb by Data > Old.

Operation of Taper

Launch Taper, and check the taper type (elliptical or linear), and direction (along-strike,

down-dip, or both). A ‘linear’ taper can be a triangle or a trapezoid.

Then choose Calculation > Go, and you will be asked for an input file. In this example,

we have selected ‘Example-3.inp’ which contains one 35°-dipping blind thrust fault.
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Answer the screen queries, which include the minimum slip at the edges, the distance

inward from the fault edges that you want the slip to taper, and the number of nested

fault patches or elements (the more you use, the smoother the slip, but the longer

Coulomb needs to run).
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The hanging-indents are replies in the screen shot above. Choose a along-strike or

down-dip taper value at least a few km less than the maximum given in the query. The

program will calculate the seismic moment and output this on the screen (write the Mo

down and put it in one of the comment lines in the input file; this is not written to the

input file it creates). To exit Taper, click once or choose Quit from the File menu.

Here is the uniform-slip fault source from the input file read by Taper (‘Example-3.inp’):

Below are the 5 fault sources from the output file, after we requested a linear taper along

strike and down-dip.

Notice in the listing above and in the grid plot below that Taper builds the file by

superimposing nested sources, each with a fraction of the total slip. Also notice that the

maximum slip in the center of the fault (what you’d get by adding up the slip for all five

sources) is larger than the uniform slip we started with, because the mean slip must be

the same in both cases.
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This file (again, renaming is advised) can now be read by Coulomb. Shown above is a plot

of the ‘grid & faults’ in Coulomb. The nested patches permit the tapered slip. As usual,

the black line is where the fault plane intersects the target depth, and the green line is

the up-dip projection of the fault to the surface.

The calculation time for a Coulomb run is roughly proportional to the number of sources

x the number of grid points; more time is required when one checks Save Result. So a

10-segment tapered slip fault will increase the run time by an order of magnitude.

However, most runs go quickly, and so this will not be a problem. We often run

variable-slip models with 100 source faults and things still go lickity-split on a

G3 PowerBook, which is not a particularly fast Mac.

Splitter lets you split or subdivide a planar fault into any number of rectangular patches.

These can then be assigned slip to create a ‘variable slip’ input model, or they can be

used to resolve stress as in an ‘Element Conditions’ file.

Operation of Splitter

1 .  Open an input file (use ‘Example-3.inp’). Change the number of patches (or

segments) along strike in the first ### column from 1 to 10, and save it with a

new name (e.g., ‘Splitter-3.inp’).

2. Launch Splitter. Choose option 3 for along-strike and down-dip patches (there

are two simpler options). Choose 6 down-dip patches. Then select ‘Splitter-3.inp’

in the dialogue box and hit return. Splitter will quit and two new files will
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appear in the folder where Splitter is located (not necessarily in the folder where

‘Splitter-3.inp’resides), ‘strike _segs.txt’ and ‘strike_dip_segs.txt’.

3 .  Open EditII or any text editor, and from within the editor, open

‘strike_dip_segs.txt’. Now the 30 x 18 km fault is split into sixty 3 x 3 km patches.

Notice that there is a logical numbering of the patches in the comment lines at

the far right of each patch. You could now assign slip values based on a variable-

slip model, rename the file, and use it as an input file.

4 .  Launch Coulomb, choose Data > Old and select ‘strike_dip_segs.txt’ (or

whatever you’ve renamed it) and hit Calculation > Go. You will see the 60 evenly-
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distributed rectangles in the grid. In the screen shot below, we changed the depth

to 2 km so the black depth-slice line would not obscure the patches.




